Skip to content

fix(packaging): Use a requires-python range instead of an exact pin - #248

Merged
joshuarli merged 1 commit into
mainfrom
fix/requires-python-range
Oct 20, 2026
Merged

joshuarli merged 1 commit into
mainfrom
fix/requires-python-range

Conversation

@sentry-junior

@sentry-junior sentry-junior Bot commented Oct 20, 2026

Copy link
Copy Markdown
Contributor

#244 set requires-python = "==3.13.16", so 1.30.0 was published with Requires-Python: ==3.13.16. That makes the release uninstallable anywhere except on exactly 3.13.16:

  • getsentry/sentry depends on sentry-devenv>=1.28.0 and runs 3.13.15.
  • getsentry/pypi builds and validates on 3.11.14/3.12.12/3.13.12/3.14.3, so update sentry_devenv==1.30.0 pypi#2637 now fails with requires-python ==3.13.16 matches none of the build pythons.

This changes it to >=3.13. devenv's own interpreter stays pinned to 3.13.16 through .python-version and install-devenv.sh, and the AGENTS.md invariant now says that. uv.lock is re-locked for the wider range.

1.30.0 can't be fixed in place. It needs a 1.30.1 release, and that release's pypi PR replaces #2637.

via @joshuarli.

--

View Junior Session [Sentry]

Co-Authored-By: Joshua Li <14209781+joshuarli@users.noreply.github.com>
@joshuarli
joshuarli enabled auto-merge (squash) October 20, 2026 21:43
@joshuarli
joshuarli disabled auto-merge October 20, 2026 21:51
@joshuarli
joshuarli merged commit a9dba67 into main Oct 20, 2026
17 checks passed
@joshuarli
joshuarli deleted the fix/requires-python-range branch October 20, 2026 21:52
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant