Skip to content

chore(deps): upgrade vulnerable packages in uv.lock and uv-pre-commit - #288

Merged
ralf0131 merged 3 commits into
alibaba:mainfrom
pylaterreur:uv-lock-security-upgrades
Oct 29, 2026
Merged

ralf0131 merged 3 commits into
alibaba:mainfrom
pylaterreur:uv-lock-security-upgrades

Conversation

@pylaterreur

Copy link
Copy Markdown
Contributor

uv audit (OSV) flagged 37 packages in the development uv.lock, and rsa
as archived. The uv-lock pre-commit hook ran uv 0.9.30, which
GHSA-hq85-5cpj-mr62 (critical: the bundled CA store trusts a
compromised emSign root) affects until 0.13.4.

Bump uv-pre-commit to 0.13.6 and relock with that uv, upgrading the
flagged packages and only the dependencies that their fixed versions
need (fastapi, pydantic, google-auth, packaging, distlib,
typing-extensions). django stays on 5.2 LTS, mcp on 1.x, protobuf on
5.29.x and google-cloud-aiplatform on 1.x. starlette and langchain move
to 1.x: no workspace constraint caps them. langchain 1.x no longer
depends on langchain-text-splitters, and google-auth 2.62 no longer
depends on rsa.

Two packages are still flagged. filelock 4.1.0 is the Python 3.10 pin:
its advisories are fixed in 4.2.1, which needs Python 3.11, and the
fixed virtualenv (21.14.9+) needs filelock>=3.24.2. opentelemetry-api
comes from the unchanged OpenTelemetry core git pin (c9ad4bc,
1.34.0.dev0); GHSA-xcq7-p3pf-p88h is fixed in 1.45.1.

CI installs through tox and does not read uv.lock.

How tested: uv lock --check (uv 0.13.6, 0.12.21, 0.9.30), pre-commit run --all-files, uv audit 37 -> 2 packages, uv sync --locked --dry-run on Python 3.10 and 3.14. Development files only; please add the Skip Changelog label.

🤖 Generated with Claude Code

https://claude.ai/code/session_01GwUvhmzgfkiZ6vo4uGyesN

pylaterreur and others added 3 commits October 27, 2026 10:53
uv audit (OSV) flagged 37 packages in the development uv.lock, and rsa
as archived. The uv-lock pre-commit hook ran uv 0.9.30, which
GHSA-hq85-5cpj-mr62 (critical: the bundled CA store trusts a
compromised emSign root) affects until 0.13.4.

Bump uv-pre-commit to 0.13.6 and relock with that uv, upgrading the
flagged packages and only the dependencies that their fixed versions
need (fastapi, pydantic, google-auth, packaging, distlib,
typing-extensions). django stays on 5.2 LTS, mcp on 1.x, protobuf on
5.29.x and google-cloud-aiplatform on 1.x. starlette and langchain move
to 1.x: no workspace constraint caps them. langchain 1.x no longer
depends on langchain-text-splitters, and google-auth 2.62 no longer
depends on rsa.

Two packages are still flagged. filelock 4.1.0 is the Python 3.10 pin:
its advisories are fixed in 4.2.1, which needs Python 3.11, and the
fixed virtualenv (21.14.9+) needs filelock>=3.24.2. opentelemetry-api
comes from the unchanged OpenTelemetry core git pin (c9ad4bc,
1.34.0.dev0); GHSA-xcq7-p3pf-p88h is fixed in 1.45.1.

CI installs through tox and does not read uv.lock.

Co-Authored-By: Claude Sonnet 5.5 <noreply@anthropic.com>
Claude-Session: https://claude.ai/code/session_01GwUvhmzgfkiZ6vo4uGyesN
The changelog check requires a CHANGELOG change or the Skip Changelog
label.

Co-Authored-By: Claude Sonnet 5.5 <noreply@anthropic.com>
Claude-Session: https://claude.ai/code/session_01GwUvhmzgfkiZ6vo4uGyesN
@ralf0131
ralf0131 merged commit c4b50fb into alibaba:main Oct 29, 2026
278 checks passed
@pylaterreur
pylaterreur deleted the uv-lock-security-upgrades branch November 1, 2026 22:32
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants