From 09428c15b09ff0081533eabba7fde6717340855b Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Fri, 23 Oct 2026 09:07:46 +0000 Subject: [PATCH] chore(deps): update fastapi requirement from >=0.143.0 to >=0.151.0 Updates the requirements on [fastapi](https://github.com/fastapi/fastapi) to permit the latest version. - [Release notes](https://github.com/fastapi/fastapi/releases) - [Commits](https://github.com/fastapi/fastapi/compare/0.143.0...0.151.0) --- updated-dependencies: - dependency-name: fastapi dependency-version: 0.151.0 dependency-type: direct:production ... Signed-off-by: dependabot[bot] --- pyproject.toml | 2 +- requirements.txt | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/pyproject.toml b/pyproject.toml index 24a1780..42e12d5 100644 --- a/pyproject.toml +++ b/pyproject.toml @@ -31,7 +31,7 @@ Changelog = "https://github.com/goun7/pkgforge/blob/master/CHANGELOG.md" [project.optional-dependencies] gui = ["PyQt6>=6.11.0"] -api = ["fastapi>=0.143.0", "uvicorn[standard]>=0.54.0", "pydantic>=2.14.1"] +api = ["fastapi>=0.151.0", "uvicorn[standard]>=0.54.0", "pydantic>=2.14.1"] dev = ["pytest>=9.1.1", "pytest-cov>=7.1.0", "pytest-timeout>=2.4.0", "hypothesis>=6.168.5", "mypy>=1.0", "bandit>=1.9.4"] [project.scripts] diff --git a/requirements.txt b/requirements.txt index 4ae4948..720656e 100644 --- a/requirements.txt +++ b/requirements.txt @@ -22,7 +22,7 @@ PyQt6>=6.11.0; python_version>="3.10" # bandit>=1.7 # ── Optional: REST API (pkgforge serve-api) ──────────────────── # Preferred install: pip install 'pkgforge[api]' (pyproject extra) -fastapi>=0.143.0 +fastapi>=0.151.0 uvicorn[standard]>=0.54.0 pydantic>=2.14.1